2014年1月15日 星期三

2014年1月14日 星期二

2013 / 12 / 25 fancybox要研究***

bornda 給的fancybox code

<script type="text/javascript">
    $(document).ready(function () {
        $("a#firmmemberlogin").fancybox({
            'width': '3',
            'height': '4',
            'showCloseButton': true,
            'autoScale': false,
            'autoDimensions': false,
            'scrolling': 'no',
            'transitionIn': 'none',
            'transitionOut': 'none',
            'type': 'iframe'
        });
        $("a#memberlogin").fancybox({
            'width': '3',
            'height': '4',
            'showCloseButton': true,
            'autoScale': false,
            'autoDimensions': false,
            'scrolling': 'no',
            'transitionIn': 'none',
            'transitionOut': 'none',
            'type': 'iframe'
        });
    });
</script>

參考書本
旗標 - 接案我最行 ! js & aj 商業範例必殺技
第二章 第六節 P.152 ~ P.161
還滿詳細的!!!


english website - How to use fancybox
http://fancybox.net/howto

2013 / 10 / 04 JavaScript Window.open()


window.open()參數列表
window.open (`page.html`, `newwindow`, `height=100, width=400, top=0, left=0, toolbar=no, menubar=no, scrollbars=no, resizable=no,location=n o, status=no`)

參數說明:

height=100 窗口高度;

width=400 窗口寬度;

top=0 窗口距離瀏覽器上方的像素值;

left=0 窗口距離瀏覽器左側的像素值;

toolbar=no 是否顯示工具列,yes為顯示、no為不顯示;

menubar=no 是否顯示選單列,yes為顯示、no為不顯示;

scrollbars=no 是否顯示滑動軸,yes為顯示、no為不顯示;

resizable=no 是否允許改變窗口大小,yes為允許、no為不允許;

location=no 是否允許顯示網址列,yes為允許、no為不允許;

status=no 是否顯示狀態檔內的訊息,yes為允許、no為不允許;


轉自:http://kyo0183.blogspot.tw/2008/10/windowopen.html

2013 / 10 / 04 網頁設計相關網站 QR可參考




【飛肯設計學苑】http://www.flycan.com.tw/board/modules/newbb/viewforum.php?forum=7

【JavaScript教材】http://neural.cs.nthu.edu.tw/jang/books/javascript/index.asp

【Meta的應用】http://famous1993.pixnet.net/blog/post/29954495-%E5%BD%B1%E9%9F%BF%E7%B6%B2%E7%AB%99%E6%8E%92%E5%BA%8F%E7%9A%84%E5%9B%A0%E7%B4%A0--meta%E6%A8%99%E7%B1%A4(%E4%B8%8A)

【JQuery局部reflash Div】http://www.baiyuxiong.com/?p=108

【JavaScript子視窗關閉、母視窗刷新】http://readily-notes.blogspot.tw/2010/11/javascript_10.html

【JavaScript子母頁面傳遞參數】http://readily-notes.blogspot.tw/2012/05/jquery-json.html

【JS視窗的變化】http://www.pt.ntu.edu.tw/hmchai/PTcomputer/hJavaScript/JSwindow.htm

【JS壇出視窗的問題】http://www.wretch.cc/blog/cschi/3977228

【JQ網頁頁籤仿YAHOO】http://abgne.tw/jquery/apply-jquery/jquery-web-tabs.html

【JQ水平移動式頁籤】http://demo.abgne.tw/jquery/0059/0059_1.html

2013 / 11 / 07 CisCO選擇題自我練習


1 . NVRAM 為存放開機設定,類似DOS的aotoexec.bat檔。


2.   sh version 顯示路由器IOS版本


3 . 設定路由器上的VTY port
           router(config)# line vty 0 4

line vty 0 4,该命令是允许用户远程登陆,即不用用户插Console线缆,只要设备连接网络,配置了接口IP地址即可远程使用Telnet、或者ssh的方式登陆到设备上,,CISCO设备一般支持16个并行的远程虚拟终端,按照编号就是:0 - 15., Line vty 0 4 就是指同时允许5个虚拟终端登陆进行配置,需注意这里配置完成后一定要注意配置enable的密码,要不Telnet是上不去的。具体如下
cisco#conf t
cisco(config)#line vty 0 4
cisco(config-line)#password cisco
cisco(config-line)#login
cisco(config-line)#exit
cisco(config)#enable password cisco
cisco(config)#

參考解說:http://zhidao.baidu.com/question/287512910.html


4 . 特權模式 #


5. telnet 失敗可能是因為vty沒設密碼,或者存取控制清單擋掉了。
存取控制清單參考:http://www.netadmin.com.tw/article_content.aspx?sn=1203020002


6 . running-config  startup-config
參考解說:http://phorum.study-area.org/index.php?topic=66666.0copy running-config startup-config 與 copy startup-config running-config
兩者有什麼不同???
ANS:running-config 是系統目前正在執行的設定檔,而startup-config則是系統載入時會讀取的設定檔。
這樣說明好了:假設我下了如下的指令
Router(config)#router rip
Router(config-router)#network 10.0.0.0
Router(config-router)#network 192.168.0.0
這份設定就會被寫入running-config
執行show running-config 就能看到如下設定
#
router rip
network 10.0.0.0
network 192.168.0.0
#
接著當你執行copy running-config startup-config 時,running-config就會被寫入startup-config ,當你下次開機時就能將設定載入,而不用重新設定。
copy startup-config running-config反之。
copy startup-config running-config使用的情況通常是你做了設定後發生一些錯誤,想回復正確設定時的狀態。
7 . show interfaces 詳解
參考網址:http://giboss.pixnet.net/blog/post/26804828-show-interface%E8%A9%B3%E8%A7%A3


10 . 0 x 2102  / 0 x 2142
參考資料:http://giboss.pixnet.net/blog/post/26804828-show-interface%E8%A9%B3%E8%A7%A3

---------------------

周老師的cisco 課程



2013 / 11 / 20 自我練習 ASP.net


基礎網站:
http://www.dotblogs.com.tw/mis2000lab/archive/2012/03/15/game_over.aspx


2014/01/15 筆記

post back 回傳還不是很懂

pageload 每click 或者活動完都會在執行page load 一次




2014 / 01 / 14 ASP.Net by Bornda



langurage : C#

 interesting.Items.Count  items 的數量

interesting.Items[i].Value.Trim()   將字串中的空白去掉

Response.Redirect("Default5.aspx"); 跳頁

開啟檔案的方法

開啟sql server,將DB檔案附加上去。
用MS開啟 -> 網站即可。

檔案

click me >___0


Session 傳值Example

<< Send file >>
protected void check_Click(object sender, EventArgs e)
    {
        Session["ac"] = "trttr";
        Response.Redirect("Default5.aspx");
    }

<< recive file >>

public partial class Default5 : System.Web.UI.Page
{
    protected void Page_Load(object sender, EventArgs e)
    {
        Response.Write(Session["ac"].ToString());
    }
}